p PatchFirst

PatchFirst · Latest vulnerabilities

gnutls28 vulnerabilities

Vulnerabilities published for gnutls28 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. USN-4233-2

    Not ratedFix available

    gnutls28 update

    USN-4233-1 disabled SHA1 being used for digital signature operations in GnuTLS. In certain network environments, certificates using SHA1 may still be in use. This update adds the %VERIFY_ALLOW_BROKEN and %VERIFY_ALLOW_SIGN_WITH_SHA1 priority strings that can be used to temporarily re-enable SHA1 until certificates can be replaced with a stronger algorithm. Original advisory details: As a security improvement, this update marks SHA1 as being untrusted for digital signature operations.

    • Update to 3.4.10-4ubuntu1.7
    Published Updated
  2. CVE-2018-10846

    Medium · CVSS 5.3EPSS 0.39%Fix available

    CVE-2018-10846

    A cache-based side channel in GnuTLS implementation that leads to plain text recovery in cross-VM attack setting was found. An attacker could use a combination of "Just in Time" Prime+probe attack in combination with Lucky-13 attack to recover plain text using crafted packets.

    • Update to 3.4.10-4ubuntu1.5
    Published Updated
  3. CVE-2018-10845

    Medium · CVSS 5.9EPSS 3.58%Fix available

    CVE-2018-10845

    It was found that the GnuTLS implementation of HMAC-SHA-384 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to conduct distinguishing attacks and plain text recovery attacks via statistical analysis of timing data using crafted packets.

    • Update to 3.4.10-4ubuntu1.5
    Published Updated
  4. CVE-2018-10844

    Medium · CVSS 5.9EPSS 3.58%Fix available

    CVE-2018-10844

    It was found that the GnuTLS implementation of HMAC-SHA-256 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to conduct distinguishing attacks and plaintext-recovery attacks via statistical analysis of timing data using crafted packets.

    • Update to 3.4.10-4ubuntu1.5
    Published Updated
  5. CVE-2016-8610

    High · CVSS 7.5EPSS 39.66%Public exploitFix available

    CVE-2016-8610

    A denial of service flaw was found in OpenSSL 0.9.8, 1.0.1, 1.0.2 through 1.0.2h, and 1.1.0 in the way the TLS/SSL protocol defined processing of ALERT packets during a connection handshake. A remote attacker could use this flaw to make a TLS/SSL server consume an excessive amount of CPU and fail to accept connections from other clients.

    • Update to 3.4.10-4ubuntu1.2
    Published Updated
  6. CVE-2017-5334

    Critical · CVSS 9.8EPSS 32.75%Fix available

    CVE-2017-5334

    Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.

    • Update to 3.4.10-4ubuntu1.2
    Published Updated
  7. CVE-2016-7444

    High · CVSS 7.5EPSS 2.44%Fix available

    CVE-2016-7444

    The gnutls_ocsp_resp_check_crt function in lib/x509/ocsp.c in GnuTLS before 3.4.15 and 3.5.x before 3.5.4 does not verify the serial length of an OCSP response, which might allow remote attackers to bypass an intended certificate validation mechanism via vectors involving trailing bytes left by gnutls_malloc.

    • Update to 3.4.10-4ubuntu1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →