p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in poco

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für poco: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2025-45766

    Hoch · CVSS 7EPSS 0,15%Keine Korrektur veröffentlicht

    CVE-2025-45766

    poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.

    Veröffentlicht Aktualisiert
  2. CVE-2025-6375

    Mittel · CVSS 4.8EPSS 0,26%Keine Korrektur veröffentlicht

    poco MultipartReader.cpp MultipartInputStream null pointer dereference

    A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.

    Veröffentlicht Aktualisiert
  3. CVE-2023-52389

    Kritisch · CVSS 9.8EPSS 0,85%Keine Korrektur veröffentlicht

    CVE-2023-52389

    UTF32Encoding.cpp in POCO has a Poco::UTF32Encoding integer overflow and resultant stack buffer overflow because Poco::UTF32Encoding::convert() and Poco::UTF32::queryConvert() may return a negative integer if a UTF-32 byte sequence evaluates to a value of 0x80000000 or higher. This is fixed in 1.11.8p2, 1.12.5p2, and 1.13.0.

    Veröffentlicht Aktualisiert
  4. CVE-2017-1000472

    Mittel · CVSS 6.5EPSS 1,68%Korrektur verfügbar

    CVE-2017-1000472

    The ZipCommon::isValidPath() function in Zip/src/ZipCommon.cpp in POCO C++ Libraries before 1.8 does not properly restrict the filename value in the ZIP header, which allows attackers to conduct absolute path traversal attacks during the ZIP decompression, and possibly create or overwrite arbitrary files, via a crafted ZIP file, related to a "file path injection vulnerability".

    • Auf 1.3.6p1-5.1ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →