p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in cups

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für cups: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 14

  1. CVE-2023-32324

    Hoch · CVSS 7.5EPSS 1,46%Korrektur verfügbar

    OpenPrinting CUPS vulnerable to heap buffer overflow

    OpenPrinting CUPS is an open source printing system. In versions 2.4.2 and prior, a heap buffer overflow vulnerability would allow a remote attacker to launch a denial of service (DoS) attack. A buffer overflow vulnerability in the function `format_log_line` could allow remote attackers to cause a DoS on the affected system. Exploitation of the vulnerability can be triggered when the configuration file `cupsd.conf` sets the value of `loglevel `to `DEBUG`. No known patches or workarounds exist at time of publication.

    • Auf 2.2.7-1ubuntu2.10 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-10001

    Mittel · CVSS 5.5EPSS 1,04%Korrektur verfügbar

    CVE-2020-10001

    An input validation issue was addressed with improved memory handling. This issue is fixed in macOS Big Sur 11.1, Security Update 2020-001 Catalina, Security Update 2020-007 Mojave. A malicious application may be able to read restricted memory.

    • Auf 2.2.7-1ubuntu2.9 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2019-8842

    Niedrig · CVSS 3.3EPSS 2,03%Korrektur verfügbar

    CVE-2019-8842

    A buffer overflow was addressed with improved bounds checking. This issue is fixed in macOS Catalina 10.15.2, Security Update 2019-002 Mojave, and Security Update 2019-007 High Sierra. In certain configurations, a remote attacker may be able to submit arbitrary print jobs.

    • Auf 2.2.7-1ubuntu2.9 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-8696

    Hoch · CVSS 8.8EPSS 2,18%Korrektur verfügbar

    CVE-2019-8696

    A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

    • Auf 2.2.7-1ubuntu2.7 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-8675

    Hoch · CVSS 8.8EPSS 2,12%Korrektur verfügbar

    CVE-2019-8675

    A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

    • Auf 2.2.7-1ubuntu2.7 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2020-3898

    Hoch · CVSS 7.8EPSS 0,39%Korrektur verfügbar

    CVE-2020-3898

    A memory corruption issue was addressed with improved validation. This issue is fixed in macOS Catalina 10.15.4. An application may be able to gain elevated privileges.

    • Auf 2.2.7-1ubuntu2.8 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2019-2228

    Mittel · CVSS 5.5EPSS 0,2%Korrektur verfügbar

    CVE-2019-2228

    In array_find of array.c, there is a possible out-of-bounds read due to an incorrect bounds check. This could lead to local information disclosure in the printer spooler with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1 Android-9 Android-10Android ID: A-111210196

    • Auf 2.2.7-1ubuntu2.8 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2019-2180

    Mittel · CVSS 5.5EPSS 0,18%Korrektur verfügbar

    CVE-2019-2180

    In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.

    • Auf 2.2.7-1ubuntu2.7 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2018-4700

    Nicht bewertetKorrektur verfügbar

    UBUNTU-CVE-2018-4700

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2018-4300. Reason: This candidate is a duplicate of CVE-2018-4300. Notes: All CVE users should reference CVE-2018-4300 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Auf 2.2.7-1ubuntu2.2 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2018-6553

    Hoch · CVSS 8.8EPSS 0,39%Korrektur verfügbar

    AppArmor cupsd Sandbox Bypass Due to Use of Hard Links

    The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.

    • Auf 2.2.7-1ubuntu2.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →