p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ghostscript · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ghostscript: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 78

  1. CVE-2020-16297

    Mittel · CVSS 5.5EPSS 2,28%Korrektur verfügbar

    CVE-2020-16297

    A buffer overflow vulnerability in FloydSteinbergDitheringC() in contrib/gdevbjca.c of Artifex Software GhostScript v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Auf 9.26~dfsg+0-0ubuntu0.18.04.13 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-16296

    Mittel · CVSS 5.5EPSS 2,05%Korrektur verfügbar

    CVE-2020-16296

    A buffer overflow vulnerability in GetNumWrongData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript from v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Auf 9.26~dfsg+0-0ubuntu0.18.04.13 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2020-16293

    Mittel · CVSS 5.5EPSS 1,77%Korrektur verfügbar

    CVE-2020-16293

    A null pointer dereference vulnerability in compose_group_nonknockout_nonblend_isolated_allmask_common() in base/gxblend.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Auf 9.26~dfsg+0-0ubuntu0.18.04.13 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-14812

    Hoch · CVSS 7.3EPSS 2,47%Korrektur verfügbar

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Auf 9.26~dfsg+0-0ubuntu0.18.04.11 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-10216

    Hoch · CVSS 7.3EPSS 2,3%Korrektur verfügbar

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Auf 9.26~dfsg+0-0ubuntu0.18.04.10 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →