p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in rabbitmq-server

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für rabbitmq-server: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2025-30219

    Mittel · CVSS 6.1EPSS 0,21%Korrektur verfügbar

    RabbitMQ has XSS Vulnerability in an Error Message in Management UI

    RabbitMQ is a messaging and streaming broker. Versions prior to 4.0.3 are vulnerable to a sophisticated attack that could modify virtual host name on disk and then make it unrecoverable (with other on disk file modifications) can lead to arbitrary JavaScript code execution in the browsers of management UI users. When a virtual host on a RabbitMQ node fails to start, recent versions will display an error message (a notification) in the management UI. The error message includes virtual host name, which was not escaped prior to open source RabbitMQ 4.0.3 and Tanzu RabbitMQ 4.0.3, 3.13.8. An attack that both makes a virtual host fail to start and

    • Auf 3.8.3-0ubuntu0.3 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-46118

    Mittel · CVSS 4.9EPSS 1,32%Korrektur verfügbar

    Denial of Service by publishing large messages over the HTTP API

    RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.

    • Auf 3.8.2-0ubuntu1.5 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2021-32719

    Niedrig · CVSS 3.1EPSS 1,42%Korrektur verfügbar

    Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ federation management plugin

    RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper <script> tag sanitization. This potentially allows for JavaScript code execution in the context of the page. The user must be signed in and have elevated permissions (manage federation upstreams and policies) for this to occur. The vulnerability is patched in RabbitMQ 3.8.18. As a workaround, disable the `rabbitmq_federation_management` plugin and use [CLI tools](https://www.rabbitmq.com/cli.htm

    • Auf 3.8.3-0ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2021-32718

    Niedrig · CVSS 3.1EPSS 1,43%Korrektur verfügbar

    Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ management UI

    RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `<script>` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.

    • Auf 3.8.3-0ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2021-22116

    Hoch · CVSS 7.5EPSS 1,39%Korrektur verfügbar

    CVE-2021-22116

    RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.

    • Auf 3.8.2-0ubuntu1.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →