p PatchFirst

CVE-2021-32718

CVE-2021-32718 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ management UI

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `<script>` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.

CVSS 3.1 · Niedrig · EPSS 1,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · database

Betroffene Produkte und Versionen

  • rabbitmq

    Softwareversionen
    • < 3.8.17: Betroffen

    Keine Korrektur veröffentlicht

  • rabbitmq-server Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.9.4-1

    Auf 3.9.4-1 aktualisieren

  • rabbitmq-server Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.9.4-1

    Auf 3.9.4-1 aktualisieren

  • rabbitmq-server Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.9.4-1

    Auf 3.9.4-1 aktualisieren

  • rabbitmq-server Ubuntu:20.04:LTS

    Softwareversionen
    • 3.7.8-4ubuntu2
    • 3.7.18-1
    • 3.8.2-0ubuntu1
    • 3.8.2-0ubuntu1.1
    • 3.8.2-0ubuntu1.2
    • 3.8.2-0ubuntu1.3
    • 3.8.2-0ubuntu1.4
    • 3.8.2-0ubuntu1.5
    • 3.8.3-0ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.8.3-0ubuntu0.2

    Auf 3.8.3-0ubuntu0.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →