p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in jruby · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für jruby: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 35

  1. CVE-2024-39908

    Mittel · CVSS 4.3EPSS 1,49%Keine Korrektur veröffentlicht

    Denial of service in REXML

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.

    Veröffentlicht Aktualisiert
  2. CVE-2024-35176

    Mittel · CVSS 5.3EPSS 2,06%Keine Korrektur veröffentlicht

    REXML contains a denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many `<`s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this vulnerability. As a workaround, don't parse untrusted XMLs.

    Veröffentlicht Aktualisiert
  3. CVE-2024-27281

    Mittel · CVSS 4.5EPSS 1,57%Keine Korrektur veröffentlicht

    CVE-2024-27281

    An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.

    Veröffentlicht Aktualisiert
  4. CVE-2024-27282

    Mittel · CVSS 6.6EPSS 0,66%Keine Korrektur veröffentlicht

    CVE-2024-27282

    An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

    Veröffentlicht Aktualisiert
  5. CVE-2023-36617

    Mittel · CVSS 5.3EPSS 1,7%Keine Korrektur veröffentlicht

    CVE-2023-36617

    A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with rfc2396_parser.rb and rfc3986_parser.rb. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version.

    Veröffentlicht Aktualisiert
  6. CVE-2023-28756

    Mittel · CVSS 5.3EPSS 2,45%Keine Korrektur veröffentlicht

    CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

    Veröffentlicht Aktualisiert
  7. CVE-2023-28755

    Mittel · CVSS 5.3EPSS 2,64%Keine Korrektur veröffentlicht

    CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    Veröffentlicht Aktualisiert
  8. CVE-2019-16255

    Hoch · CVSS 8.1EPSS 4,19%Keine Korrektur veröffentlicht

    CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    Veröffentlicht Aktualisiert
  9. CVE-2019-16201

    Hoch · CVSS 7.5EPSS 5,09%Keine Korrektur veröffentlicht

    CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →