p PatchFirst

CVE-2018-1000613

CVE-2018-1000613

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.

CVSS 9.8 · Crítica · EPSS 4,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • bouncycastle Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.60-1

    Actualiza a 1.60-1

  • bouncycastle Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.60-1

    Actualiza a 1.60-1

  • bouncycastle Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.60-1

    Actualiza a 1.60-1

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →