p PatchFirst

CVE-2018-1000613

CVE-2018-1000613

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.

CVSS 9.8 · Critique · EPSS 4,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • bouncycastle Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.60-1

    Mettez à jour vers 1.60-1

  • bouncycastle Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.60-1

    Mettez à jour vers 1.60-1

  • bouncycastle Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.60-1

    Mettez à jour vers 1.60-1

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →