p PatchFirst

CVE-2018-1000613

CVE-2018-1000613

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.

CVSS 9.8 · Critical · EPSS 4.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • bouncycastle Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.60-1

    Update to 1.60-1

  • bouncycastle Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.60-1

    Update to 1.60-1

  • bouncycastle Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.60-1

    Update to 1.60-1

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Versions
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →