p PatchFirst

CVE-2018-1000807

CVE-2018-1000807

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

CVSS 8.1 · Alta · EPSS 4,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • pyopenssl Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 17.5.0-1

    Actualiza a 17.5.0-1

  • pyopenssl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 17.5.0-1

    Actualiza a 17.5.0-1

  • pyopenssl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 17.5.0-1

    Actualiza a 17.5.0-1

  • pyopenssl PyPI

    Versiones
    • 0.10
    • 0.11
    • 0.12
    • 0.13
    • 0.13.1
    • 0.14
    • 0.15
    • 0.15.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 16.0.0
    • 16.1.0
    • 16.2.0
    • 17.0.0
    • 17.1.0
    • 17.2.0
    • 17.3.0
    • 17.4.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 17.5.0

    Actualiza a 17.5.0

  • pyopenssl Ubuntu:16.04:LTS

    Versiones
    • 0.15.1-2build1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.15.1-2ubuntu0.2

    Actualiza a 0.15.1-2ubuntu0.2

Fuentes originales

Comprueba tu servidor →