p PatchFirst

CVE-2018-1000807

CVE-2018-1000807

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

CVSS 8.1 · Élevée · EPSS 4,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · python

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • pyopenssl Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 17.5.0-1

    Mettez à jour vers 17.5.0-1

  • pyopenssl Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 17.5.0-1

    Mettez à jour vers 17.5.0-1

  • pyopenssl Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 17.5.0-1

    Mettez à jour vers 17.5.0-1

  • pyopenssl PyPI

    Versions du logiciel
    • 0.10
    • 0.11
    • 0.12
    • 0.13
    • 0.13.1
    • 0.14
    • 0.15
    • 0.15.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 16.0.0
    • 16.1.0
    • 16.2.0
    • 17.0.0
    • 17.1.0
    • 17.2.0
    • 17.3.0
    • 17.4.0
    Plages de versions concernées
    • ECOSYSTEM: < 17.5.0

    Mettez à jour vers 17.5.0

  • pyopenssl Ubuntu:16.04:LTS

    Versions du logiciel
    • 0.15.1-2build1
    Plages de versions concernées
    • ECOSYSTEM: < 0.15.1-2ubuntu0.2

    Mettez à jour vers 0.15.1-2ubuntu0.2

Sources originales

Vérifiez votre serveur →