p PatchFirst

CVE-2018-1000807

CVE-2018-1000807

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

CVSS 8.1 · Hoch · EPSS 4,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • pyopenssl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 17.5.0-1

    Auf 17.5.0-1 aktualisieren

  • pyopenssl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 17.5.0-1

    Auf 17.5.0-1 aktualisieren

  • pyopenssl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 17.5.0-1

    Auf 17.5.0-1 aktualisieren

  • pyopenssl PyPI

    Softwareversionen
    • 0.10
    • 0.11
    • 0.12
    • 0.13
    • 0.13.1
    • 0.14
    • 0.15
    • 0.15.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 16.0.0
    • 16.1.0
    • 16.2.0
    • 17.0.0
    • 17.1.0
    • 17.2.0
    • 17.3.0
    • 17.4.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 17.5.0

    Auf 17.5.0 aktualisieren

  • pyopenssl Ubuntu:16.04:LTS

    Softwareversionen
    • 0.15.1-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.15.1-2ubuntu0.2

    Auf 0.15.1-2ubuntu0.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →