CVE-2021-21408
CVE-2021-21408 · Access to restricted PHP code by dynamic static class access in smarty
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.
CVSS 8.8 · Alta · EPSS 2,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
smarty
- Versiones
- < 3.1.43: Afectada
- >= 4.0.0, < 4.0.3: Afectada
Sin corrección publicada
smarty3 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.45-1
Actualiza a 3.1.45-1
smarty3 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.45-1
Actualiza a 3.1.45-1
smarty3 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.45-1
Actualiza a 3.1.45-1
smarty4 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.1-1
Actualiza a 4.1.1-1
smarty4 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.1-1
Actualiza a 4.1.1-1
smarty4 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.1-1
Actualiza a 4.1.1-1
smarty/smarty Packagist
- Versiones
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- v3.1.33
- v3.1.34
- v3.1.35
- v3.1.36
- v3.1.37
- v3.1.37.1
- v3.1.38
- v3.1.39
- v3.1.40
- v3.1.41
- v3.1.42
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.43
Actualiza a 3.1.43
smarty/smarty Packagist
- Versiones
- v4.0.0
- v4.0.1
- v4.0.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.0.0, < 4.0.3
Actualiza a 4.0.3
smarty3 Ubuntu:Pro:16.04:LTS
- Versiones
- 3.1.21-1
- 3.1.21-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.21-1ubuntu1+esm1
Actualiza a 3.1.21-1ubuntu1+esm1
smarty3 Ubuntu:18.04:LTS
- Versiones
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
Actualiza a 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
smarty3 Ubuntu:Pro:20.04:LTS
- Versiones
- 3.1.33+20180830.1.3a78a21f+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
Actualiza a 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
smarty3 Ubuntu:22.04:LTS
- Versiones
- 3.1.39-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.39-2ubuntu1
Actualiza a 3.1.39-2ubuntu1
Fuentes originales
- https://github.com/smarty-php/smarty/security/advisories/GHSA-4h9c-v5vg-5m6m
- https://github.com/smarty-php/smarty/commit/19ae410bf56007a5ef24441cdc6414619cfaf664
- https://github.com/smarty-php/smarty/releases/tag/v3.1.43
- https://github.com/smarty-php/smarty/releases/tag/v4.0.3
- https://lists.debian.org/debian-lts-announce/2022/05/msg00005.html
- https://www.debian.org/security/2022/dsa-5151
- https://security.gentoo.org/glsa/202209-09
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L777JIBIWJV34HS7LXPIDWASG7TT4LNI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BRAJVDRGCIY5UZ2PQHKDTT7RMKG6WJQQ/
- https://nvd.nist.gov/vuln/detail/CVE-2021-21408