p PatchFirst

CVE-2021-21408

CVE-2021-21408 · Access to restricted PHP code by dynamic static class access in smarty

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.

CVSS 8.8 · Hoch · EPSS 2,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • smarty

    Softwareversionen
    • < 3.1.43: Betroffen
    • >= 4.0.0, < 4.0.3: Betroffen

    Keine Korrektur veröffentlicht

  • smarty3 Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45-1

    Auf 3.1.45-1 aktualisieren

  • smarty3 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45-1

    Auf 3.1.45-1 aktualisieren

  • smarty3 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45-1

    Auf 3.1.45-1 aktualisieren

  • smarty4 Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.1.1-1

    Auf 4.1.1-1 aktualisieren

  • smarty4 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.1.1-1

    Auf 4.1.1-1 aktualisieren

  • smarty4 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.1.1-1

    Auf 4.1.1-1 aktualisieren

  • smarty/smarty Packagist

    Softwareversionen
    • v2.6.24
    • v2.6.25
    • v2.6.26
    • v2.6.27
    • v2.6.28
    • v2.6.29
    • v2.6.30
    • v2.6.31
    • v2.6.33
    • v3.1.11
    • v3.1.12
    • v3.1.13
    • v3.1.14
    • v3.1.15
    • v3.1.16
    • v3.1.17
    • v3.1.18
    • v3.1.19
    • v3.1.20
    • v3.1.21
    • v3.1.23
    • v3.1.24
    • v3.1.25
    • v3.1.26
    • v3.1.27
    • v3.1.28
    • v3.1.29
    • v3.1.30
    • v3.1.31
    • v3.1.32
    • v3.1.33
    • v3.1.34
    • v3.1.35
    • v3.1.36
    • v3.1.37
    • v3.1.37.1
    • v3.1.38
    • v3.1.39
    • v3.1.40
    • v3.1.41
    • v3.1.42
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.43

    Auf 3.1.43 aktualisieren

  • smarty/smarty Packagist

    Softwareversionen
    • v4.0.0
    • v4.0.1
    • v4.0.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.3

    Auf 4.0.3 aktualisieren

  • smarty3 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 3.1.21-1
    • 3.1.21-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.21-1ubuntu1+esm1

    Auf 3.1.21-1ubuntu1+esm1 aktualisieren

  • smarty3 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.1.31+20161214.1.c7d42e4+selfpack1-2
    • 3.1.31+20161214.1.c7d42e4+selfpack1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1

    Auf 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1 aktualisieren

  • smarty3 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 3.1.33+20180830.1.3a78a21f+selfpack1-1
    • 3.1.34+20190228.1.c9f0de05+selfpack1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1

    Auf 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1 aktualisieren

  • smarty3 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.1.39-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.39-2ubuntu1

    Auf 3.1.39-2ubuntu1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →