p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de smarty3

Vulnerabilidades publicadas para smarty3 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 7

  1. CVE-2021-29454

    Alta · CVSS 8.1EPSS 1,8%Corrección disponible

    Sandbox Escape by math function in smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.

    • Actualiza a 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publicación Actualización
  2. CVE-2021-21408

    Alta · CVSS 8.8EPSS 2,08%Corrección disponible

    Access to restricted PHP code by dynamic static class access in smarty

    Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.

    • Actualiza a 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publicación Actualización
  3. CVE-2018-13982

    Alta · CVSS 7.5EPSS 3,46%Corrección disponible

    CVE-2018-13982

    Smarty_Security::isTrustedResourceDir() in Smarty before 3.1.33 is prone to a path traversal vulnerability due to insufficient template code sanitization. This allows attackers controlling the executed template code to bypass the trusted directory security restriction and read arbitrary files.

    • Actualiza a 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publicación Actualización
  4. CVE-2018-16831

    Media · CVSS 5.9EPSS 2,66%Corrección disponible

    CVE-2018-16831

    Smarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.

    • Actualiza a 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →