CVE-2021-32718
CVE-2021-32718 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ management UI
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `<script>` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.
CVSS 3.1 · Baja · EPSS 1,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
rabbitmq
- Versiones
- < 3.8.17: Afectada
Sin corrección publicada
rabbitmq-server Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.9.4-1
Actualiza a 3.9.4-1
rabbitmq-server Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.9.4-1
Actualiza a 3.9.4-1
rabbitmq-server Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.9.4-1
Actualiza a 3.9.4-1
rabbitmq-server Ubuntu:20.04:LTS
- Versiones
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.3-0ubuntu0.2
Actualiza a 3.8.3-0ubuntu0.2