p PatchFirst

CVE-2021-32718

CVE-2021-32718 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ management UI

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `<script>` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.

CVSS 3.1 · Faible · EPSS 1,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · database

Produits et versions concernés

  • rabbitmq

    Versions du logiciel
    • < 3.8.17: Concernée

    Aucun correctif publié

  • rabbitmq-server Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 3.9.4-1

    Mettez à jour vers 3.9.4-1

  • rabbitmq-server Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 3.9.4-1

    Mettez à jour vers 3.9.4-1

  • rabbitmq-server Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 3.9.4-1

    Mettez à jour vers 3.9.4-1

  • rabbitmq-server Ubuntu:20.04:LTS

    Versions du logiciel
    • 3.7.8-4ubuntu2
    • 3.7.18-1
    • 3.8.2-0ubuntu1
    • 3.8.2-0ubuntu1.1
    • 3.8.2-0ubuntu1.2
    • 3.8.2-0ubuntu1.3
    • 3.8.2-0ubuntu1.4
    • 3.8.2-0ubuntu1.5
    • 3.8.3-0ubuntu0.1
    Plages de versions concernées
    • ECOSYSTEM: < 3.8.3-0ubuntu0.2

    Mettez à jour vers 3.8.3-0ubuntu0.2

Sources originales

Vérifiez votre serveur →