CVE-2021-37695
CVE-2021-37695 · Execution of JavaScript code using malformed HTML in ckeditor
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Fake Objects](https://ckeditor.com/cke4/addon/fakeobjects) package. The vulnerability allowed to inject malformed Fake Objects HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version < 4.16.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.
CVSS 7.3 · Alta · EPSS 1,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
ckeditor4
- Versiones
- < 4.16.2: Afectada
Sin corrección publicada
ckeditor Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.16.2+dfsg-1
Actualiza a 4.16.2+dfsg-1
ckeditor4 npm
- Intervalos de versiones afectados
- SEMVER: < 4.16.2
Actualiza a 4.16.2
ckeditor Ubuntu:Pro:16.04:LTS
- Versiones
- 4.4.4+dfsg1-3
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.7+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
Actualiza a 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
ldap-account-manager Ubuntu:16.04:LTS
- Versiones
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:16.04:LTS
- Versiones
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ckeditor Ubuntu:18.04:LTS
- Versiones
- 4.5.7+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.18.04.1
Actualiza a 4.5.7+dfsg-2ubuntu0.18.04.1
ckeditor3 Ubuntu:18.04:LTS
- Versiones
- 3.6.6.1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:18.04:LTS
- Versiones
- 5.7-1
- 6.1-1
- 6.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:Pro:18.04:LTS
- Versiones
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ckeditor Ubuntu:20.04:LTS
- Versiones
- 4.11.1+dfsg-1
- 4.12.1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.12.1+dfsg-1ubuntu0.1
Actualiza a 4.12.1+dfsg-1ubuntu0.1
ckeditor3 Ubuntu:20.04:LTS
- Versiones
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:20.04:LTS
- Versiones
- 6.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:20.04:LTS
- Versiones
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ckeditor3 Ubuntu:22.04:LTS
- Versiones
- 3.6.6.1+dfsg-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:22.04:LTS
- Versiones
- 7.5-1
- 7.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:22.04:LTS
- Versiones
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ckeditor3 Ubuntu:24.04:LTS
- Versiones
- 3.6.6.1+dfsg-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:24.04:LTS
- Versiones
- 8.3-1
- 8.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:24.04:LTS
- Versiones
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:25.10
- Versiones
- 9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:25.10
- Versiones
- 4.4.7+dfsg-4syncable1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:26.04:LTS
- Versiones
- 9.0-1
- 9.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
request-tracker4 Ubuntu:26.04:LTS
- Versiones
- 4.4.7+dfsg-4syncable1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-m94c-37g6-cjhc
- https://github.com/ckeditor/ckeditor4/commit/de3c001540715f9c3801aaa38a1917de46cfcf58
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00007.html
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-37695