CVE-2021-37695
CVE-2021-37695 · Execution of JavaScript code using malformed HTML in ckeditor
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Fake Objects](https://ckeditor.com/cke4/addon/fakeobjects) package. The vulnerability allowed to inject malformed Fake Objects HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version < 4.16.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.
CVSS 7.3 · Hoch · EPSS 1,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
ckeditor4
- Softwareversionen
- < 4.16.2: Betroffen
Keine Korrektur veröffentlicht
ckeditor Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.16.2+dfsg-1
Auf 4.16.2+dfsg-1 aktualisieren
ckeditor4 npm
- Betroffene Versionsbereiche
- SEMVER: < 4.16.2
Auf 4.16.2 aktualisieren
ckeditor Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.4.4+dfsg1-3
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.7+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
Auf 4.5.7+dfsg-2ubuntu0.16.04.1~esm1 aktualisieren
ldap-account-manager Ubuntu:16.04:LTS
- Softwareversionen
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:16.04:LTS
- Softwareversionen
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor Ubuntu:18.04:LTS
- Softwareversionen
- 4.5.7+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.18.04.1
Auf 4.5.7+dfsg-2ubuntu0.18.04.1 aktualisieren
ckeditor3 Ubuntu:18.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:18.04:LTS
- Softwareversionen
- 5.7-1
- 6.1-1
- 6.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor Ubuntu:20.04:LTS
- Softwareversionen
- 4.11.1+dfsg-1
- 4.12.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.12.1+dfsg-1ubuntu0.1
Auf 4.12.1+dfsg-1ubuntu0.1 aktualisieren
ckeditor3 Ubuntu:20.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:20.04:LTS
- Softwareversionen
- 6.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:20.04:LTS
- Softwareversionen
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:22.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:22.04:LTS
- Softwareversionen
- 7.5-1
- 7.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:22.04:LTS
- Softwareversionen
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:24.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:24.04:LTS
- Softwareversionen
- 8.3-1
- 8.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:24.04:LTS
- Softwareversionen
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:25.10
- Softwareversionen
- 9.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:25.10
- Softwareversionen
- 4.4.7+dfsg-4syncable1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:26.04:LTS
- Softwareversionen
- 9.0-1
- 9.0-1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:26.04:LTS
- Softwareversionen
- 4.4.7+dfsg-4syncable1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-m94c-37g6-cjhc
- https://github.com/ckeditor/ckeditor4/commit/de3c001540715f9c3801aaa38a1917de46cfcf58
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00007.html
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-37695