p PatchFirst

CVE-2021-41091

CVE-2021-41091 · Insufficiently restricted permissions on data directory in Docker Engine

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where the data directory (typically `/var/lib/docker`) contained subdirectories with insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as `setuid`), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This bug has been fixed in Moby (Docker Engine) 20.10.9. Users should update to this version as soon as possible. Running containers should be stopped and restarted for the permissions to be fixed. For users unable to upgrade limit access to the host to trusted users. Limit access to host volumes to trusted containers.

CVSS 6.3 · Media · EPSS 2,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · containers

Productos y versiones afectados

  • docker engine

    Versiones
    • < 20.10.9: Afectada

    Sin corrección publicada

  • docker.io Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 20.10.10+dfsg1-1

    Actualiza a 20.10.10+dfsg1-1

  • docker.io Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 20.10.10+dfsg1-1

    Actualiza a 20.10.10+dfsg1-1

  • docker.io Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 20.10.10+dfsg1-1

    Actualiza a 20.10.10+dfsg1-1

  • docker.io Ubuntu:18.04:LTS

    Versiones
    • 1.13.1-0ubuntu6
    • 17.03.2-0ubuntu1
    • 17.03.2-0ubuntu3
    • 17.03.2-0ubuntu5
    • 17.12.1-0ubuntu1
    • 18.06.1-0ubuntu1~18.04.1
    • 18.06.1-0ubuntu1.2~18.04.1
    • 18.09.2-0ubuntu1~18.04.1
    • 18.09.5-0ubuntu1~18.04.2
    • 18.09.7-0ubuntu1~18.04.1
    • 18.09.7-0ubuntu1~18.04.3
    • 18.09.7-0ubuntu1~18.04.4
    • 19.03.6-0ubuntu1~18.04.1
    • 19.03.6-0ubuntu1~18.04.2
    • 19.03.6-0ubuntu1~18.04.3
    • 20.10.2-0ubuntu1~18.04.2
    • 20.10.2-0ubuntu1~18.04.3
    • 20.10.7-0ubuntu1~18.04.1
    • 20.10.7-0ubuntu1~18.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 20.10.7-0ubuntu5~18.04.2

    Actualiza a 20.10.7-0ubuntu5~18.04.2

  • docker.io Ubuntu:20.04:LTS

    Versiones
    • 19.03.2-0ubuntu1
    • 19.03.6-0ubuntu1
    • 19.03.8-0ubuntu1
    • 19.03.8-0ubuntu1.20.04
    • 19.03.8-0ubuntu1.20.04.1
    • 19.03.8-0ubuntu1.20.04.2
    • 20.10.2-0ubuntu1~20.04.2
    • 20.10.2-0ubuntu1~20.04.3
    • 20.10.7-0ubuntu1~20.04.1
    • 20.10.7-0ubuntu1~20.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 20.10.7-0ubuntu5~20.04.1

    Actualiza a 20.10.7-0ubuntu5~20.04.1

  • docker.io Ubuntu:22.04:LTS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 20.10.7-0ubuntu5

    Actualiza a 20.10.7-0ubuntu5

Fuentes originales

Comprueba tu servidor →