p PatchFirst

CVE-2021-41091

CVE-2021-41091 · Insufficiently restricted permissions on data directory in Docker Engine

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where the data directory (typically `/var/lib/docker`) contained subdirectories with insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as `setuid`), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This bug has been fixed in Moby (Docker Engine) 20.10.9. Users should update to this version as soon as possible. Running containers should be stopped and restarted for the permissions to be fixed. For users unable to upgrade limit access to the host to trusted users. Limit access to host volumes to trusted containers.

CVSS 6.3 · Mittel · EPSS 2,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · containers

Betroffene Produkte und Versionen

  • docker engine

    Softwareversionen
    • < 20.10.9: Betroffen

    Keine Korrektur veröffentlicht

  • docker.io Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.10+dfsg1-1

    Auf 20.10.10+dfsg1-1 aktualisieren

  • docker.io Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.10+dfsg1-1

    Auf 20.10.10+dfsg1-1 aktualisieren

  • docker.io Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.10+dfsg1-1

    Auf 20.10.10+dfsg1-1 aktualisieren

  • docker.io Ubuntu:18.04:LTS

    Softwareversionen
    • 1.13.1-0ubuntu6
    • 17.03.2-0ubuntu1
    • 17.03.2-0ubuntu3
    • 17.03.2-0ubuntu5
    • 17.12.1-0ubuntu1
    • 18.06.1-0ubuntu1~18.04.1
    • 18.06.1-0ubuntu1.2~18.04.1
    • 18.09.2-0ubuntu1~18.04.1
    • 18.09.5-0ubuntu1~18.04.2
    • 18.09.7-0ubuntu1~18.04.1
    • 18.09.7-0ubuntu1~18.04.3
    • 18.09.7-0ubuntu1~18.04.4
    • 19.03.6-0ubuntu1~18.04.1
    • 19.03.6-0ubuntu1~18.04.2
    • 19.03.6-0ubuntu1~18.04.3
    • 20.10.2-0ubuntu1~18.04.2
    • 20.10.2-0ubuntu1~18.04.3
    • 20.10.7-0ubuntu1~18.04.1
    • 20.10.7-0ubuntu1~18.04.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.7-0ubuntu5~18.04.2

    Auf 20.10.7-0ubuntu5~18.04.2 aktualisieren

  • docker.io Ubuntu:20.04:LTS

    Softwareversionen
    • 19.03.2-0ubuntu1
    • 19.03.6-0ubuntu1
    • 19.03.8-0ubuntu1
    • 19.03.8-0ubuntu1.20.04
    • 19.03.8-0ubuntu1.20.04.1
    • 19.03.8-0ubuntu1.20.04.2
    • 20.10.2-0ubuntu1~20.04.2
    • 20.10.2-0ubuntu1~20.04.3
    • 20.10.7-0ubuntu1~20.04.1
    • 20.10.7-0ubuntu1~20.04.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.7-0ubuntu5~20.04.1

    Auf 20.10.7-0ubuntu5~20.04.1 aktualisieren

  • docker.io Ubuntu:22.04:LTS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.7-0ubuntu5

    Auf 20.10.7-0ubuntu5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →