CVE-2021-41091
CVE-2021-41091 · Insufficiently restricted permissions on data directory in Docker Engine
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where the data directory (typically `/var/lib/docker`) contained subdirectories with insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as `setuid`), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This bug has been fixed in Moby (Docker Engine) 20.10.9. Users should update to this version as soon as possible. Running containers should be stopped and restarted for the permissions to be fixed. For users unable to upgrade limit access to the host to trusted users. Limit access to host volumes to trusted containers.
CVSS 6.3 · Moyenne · EPSS 2,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · containers
Produits et versions concernés
docker engine
- Versions du logiciel
- < 20.10.9: Concernée
Aucun correctif publié
docker.io Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 20.10.10+dfsg1-1
Mettez à jour vers 20.10.10+dfsg1-1
docker.io Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 20.10.10+dfsg1-1
Mettez à jour vers 20.10.10+dfsg1-1
docker.io Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 20.10.10+dfsg1-1
Mettez à jour vers 20.10.10+dfsg1-1
docker.io Ubuntu:18.04:LTS
- Versions du logiciel
- 1.13.1-0ubuntu6
- 17.03.2-0ubuntu1
- 17.03.2-0ubuntu3
- 17.03.2-0ubuntu5
- 17.12.1-0ubuntu1
- 18.06.1-0ubuntu1~18.04.1
- 18.06.1-0ubuntu1.2~18.04.1
- 18.09.2-0ubuntu1~18.04.1
- 18.09.5-0ubuntu1~18.04.2
- 18.09.7-0ubuntu1~18.04.1
- 18.09.7-0ubuntu1~18.04.3
- 18.09.7-0ubuntu1~18.04.4
- 19.03.6-0ubuntu1~18.04.1
- 19.03.6-0ubuntu1~18.04.2
- 19.03.6-0ubuntu1~18.04.3
- 20.10.2-0ubuntu1~18.04.2
- 20.10.2-0ubuntu1~18.04.3
- 20.10.7-0ubuntu1~18.04.1
- 20.10.7-0ubuntu1~18.04.2
- Plages de versions concernées
- ECOSYSTEM: < 20.10.7-0ubuntu5~18.04.2
Mettez à jour vers 20.10.7-0ubuntu5~18.04.2
docker.io Ubuntu:20.04:LTS
- Versions du logiciel
- 19.03.2-0ubuntu1
- 19.03.6-0ubuntu1
- 19.03.8-0ubuntu1
- 19.03.8-0ubuntu1.20.04
- 19.03.8-0ubuntu1.20.04.1
- 19.03.8-0ubuntu1.20.04.2
- 20.10.2-0ubuntu1~20.04.2
- 20.10.2-0ubuntu1~20.04.3
- 20.10.7-0ubuntu1~20.04.1
- 20.10.7-0ubuntu1~20.04.2
- Plages de versions concernées
- ECOSYSTEM: < 20.10.7-0ubuntu5~20.04.1
Mettez à jour vers 20.10.7-0ubuntu5~20.04.1
docker.io Ubuntu:22.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 20.10.7-0ubuntu5
Mettez à jour vers 20.10.7-0ubuntu5
Sources originales
- https://github.com/moby/moby/security/advisories/GHSA-3fwx-pjgw-3558
- https://github.com/moby/moby/commit/f0ab919f518c47240ea0e72d0999576bb8008e64
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/
- https://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41091