p PatchFirst

CVE-2021-41990

CVE-2021-41990

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur.

CVSS 7.5 · Alta · EPSS 7,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • strongswan Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.4-1

    Actualiza a 5.9.4-1

  • strongswan Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.4-1

    Actualiza a 5.9.4-1

  • strongswan Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.4-1

    Actualiza a 5.9.4-1

  • strongswan Ubuntu:18.04:LTS

    Versiones
    • 5.5.1-4ubuntu2
    • 5.5.1-4ubuntu3
    • 5.6.1-2ubuntu1
    • 5.6.1-2ubuntu2
    • 5.6.1-2ubuntu3
    • 5.6.1-2ubuntu4
    • 5.6.2-1ubuntu2
    • 5.6.2-1ubuntu2.2
    • 5.6.2-1ubuntu2.3
    • 5.6.2-1ubuntu2.4
    • 5.6.2-1ubuntu2.5
    • 5.6.2-1ubuntu2.6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.6.2-1ubuntu2.7

    Actualiza a 5.6.2-1ubuntu2.7

  • strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS

    Versiones
    • 5.6.2-1ubuntu2.fips.2.5.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.7.1

    Actualiza a 5.6.2-1ubuntu2.fips.2.7.1

  • strongswan Ubuntu:Pro:FIPS:18.04:LTS

    Versiones
    • 5.6.2-1ubuntu2.fips.2.4.2
    • 5.6.2-1ubuntu2.fips.2.5.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • strongswan Ubuntu:20.04:LTS

    Versiones
    • 5.7.2-1ubuntu3
    • 5.8.1-1ubuntu1
    • 5.8.2-1ubuntu1
    • 5.8.2-1ubuntu2
    • 5.8.2-1ubuntu3
    • 5.8.2-1ubuntu3.1
    • 5.8.2-1ubuntu3.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.8.2-1ubuntu3.3

    Actualiza a 5.8.2-1ubuntu3.3

  • strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS

    Versiones
    • 5.8.2-1ubuntu3.fips.3.1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.3.1

    Actualiza a 5.8.2-1ubuntu3.fips.3.3.1

  • strongswan Ubuntu:Pro:FIPS:20.04:LTS

    Versiones
    • 5.8.2-1ubuntu3.fips.3.1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • strongswan Ubuntu:22.04:LTS

    Versiones
    • 5.9.1-1ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.9.1-1ubuntu3.1

    Actualiza a 5.9.1-1ubuntu3.1

Fuentes originales

Comprueba tu servidor →