p PatchFirst

CVE-2021-41990

CVE-2021-41990

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur.

CVSS 7.5 · Hoch · EPSS 7,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • strongswan Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.4-1

    Auf 5.9.4-1 aktualisieren

  • strongswan Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.4-1

    Auf 5.9.4-1 aktualisieren

  • strongswan Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.4-1

    Auf 5.9.4-1 aktualisieren

  • strongswan Ubuntu:18.04:LTS

    Softwareversionen
    • 5.5.1-4ubuntu2
    • 5.5.1-4ubuntu3
    • 5.6.1-2ubuntu1
    • 5.6.1-2ubuntu2
    • 5.6.1-2ubuntu3
    • 5.6.1-2ubuntu4
    • 5.6.2-1ubuntu2
    • 5.6.2-1ubuntu2.2
    • 5.6.2-1ubuntu2.3
    • 5.6.2-1ubuntu2.4
    • 5.6.2-1ubuntu2.5
    • 5.6.2-1ubuntu2.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.6.2-1ubuntu2.7

    Auf 5.6.2-1ubuntu2.7 aktualisieren

  • strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS

    Softwareversionen
    • 5.6.2-1ubuntu2.fips.2.5.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.7.1

    Auf 5.6.2-1ubuntu2.fips.2.7.1 aktualisieren

  • strongswan Ubuntu:Pro:FIPS:18.04:LTS

    Softwareversionen
    • 5.6.2-1ubuntu2.fips.2.4.2
    • 5.6.2-1ubuntu2.fips.2.5.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • strongswan Ubuntu:20.04:LTS

    Softwareversionen
    • 5.7.2-1ubuntu3
    • 5.8.1-1ubuntu1
    • 5.8.2-1ubuntu1
    • 5.8.2-1ubuntu2
    • 5.8.2-1ubuntu3
    • 5.8.2-1ubuntu3.1
    • 5.8.2-1ubuntu3.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.8.2-1ubuntu3.3

    Auf 5.8.2-1ubuntu3.3 aktualisieren

  • strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS

    Softwareversionen
    • 5.8.2-1ubuntu3.fips.3.1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.3.1

    Auf 5.8.2-1ubuntu3.fips.3.3.1 aktualisieren

  • strongswan Ubuntu:Pro:FIPS:20.04:LTS

    Softwareversionen
    • 5.8.2-1ubuntu3.fips.3.1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • strongswan Ubuntu:22.04:LTS

    Softwareversionen
    • 5.9.1-1ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.1-1ubuntu3.1

    Auf 5.9.1-1ubuntu3.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →