CVE-2021-41990
CVE-2021-41990
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur.
CVSS 7.5 · Élevée · EPSS 7,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
strongswan Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.9.4-1
Mettez à jour vers 5.9.4-1
strongswan Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.9.4-1
Mettez à jour vers 5.9.4-1
strongswan Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.9.4-1
Mettez à jour vers 5.9.4-1
strongswan Ubuntu:18.04:LTS
- Versions du logiciel
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- Plages de versions concernées
- ECOSYSTEM: < 5.6.2-1ubuntu2.7
Mettez à jour vers 5.6.2-1ubuntu2.7
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions du logiciel
- 5.6.2-1ubuntu2.fips.2.5.1
- Plages de versions concernées
- ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.7.1
Mettez à jour vers 5.6.2-1ubuntu2.fips.2.7.1
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Versions du logiciel
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:20.04:LTS
- Versions du logiciel
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- Plages de versions concernées
- ECOSYSTEM: < 5.8.2-1ubuntu3.3
Mettez à jour vers 5.8.2-1ubuntu3.3
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versions du logiciel
- 5.8.2-1ubuntu3.fips.3.1.2
- Plages de versions concernées
- ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.3.1
Mettez à jour vers 5.8.2-1ubuntu3.fips.3.3.1
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Versions du logiciel
- 5.8.2-1ubuntu3.fips.3.1.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:22.04:LTS
- Versions du logiciel
- 5.9.1-1ubuntu3
- Plages de versions concernées
- ECOSYSTEM: < 5.9.1-1ubuntu3.1
Mettez à jour vers 5.9.1-1ubuntu3.1
Sources originales
- https://github.com/strongswan/strongswan/releases/tag/5.9.4
- https://www.strongswan.org/blog/2021/10/18/strongswan-vulnerability-%28cve-2021-41990%29.html
- https://www.debian.org/security/2021/dsa-4989
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5FJSATD2R2XHTG4P63GCMQ2N7EWKMME5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WQSQ3BEC22NF4NCDZVCT4P3Q2ZIAJXGJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y3TQ32JLJOBJDB2EJKSX2PBPB5NFG2D4/
- https://cert-portal.siemens.com/productcert/pdf/ssa-539476.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41990