CVE-2022-31172
CVE-2022-31172 · OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.
CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
openzeppelin-contracts
- Versiones
- >= 4.1.0, < 4.7.1: Afectada
Sin corrección publicada
@openzeppelin/contracts npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.1.0, < 4.7.1
Actualiza a 4.7.1
@openzeppelin/contracts-upgradeable npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.1.0, < 4.7.1
Actualiza a 4.7.1