CVE-2022-31172
CVE-2022-31172 · OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.
CVSS 7.5 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
openzeppelin-contracts
- Versions du logiciel
- >= 4.1.0, < 4.7.1: Concernée
Aucun correctif publié
@openzeppelin/contracts npm
- Plages de versions concernées
- SEMVER: ≥ 4.1.0, < 4.7.1
Mettez à jour vers 4.7.1
@openzeppelin/contracts-upgradeable npm
- Plages de versions concernées
- SEMVER: ≥ 4.1.0, < 4.7.1
Mettez à jour vers 4.7.1