CVE-2022-31172
CVE-2022-31172 · OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.
CVSS 7.5 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
openzeppelin-contracts
- Versions
- >= 4.1.0, < 4.7.1: Affected
No fix published
@openzeppelin/contracts npm
- Affected ranges
- SEMVER: ≥ 4.1.0, < 4.7.1
Update to 4.7.1
@openzeppelin/contracts-upgradeable npm
- Affected ranges
- SEMVER: ≥ 4.1.0, < 4.7.1
Update to 4.7.1