p PatchFirst

CVE-2022-41556

CVE-2022-41556

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

CVSS 7.5 · Alta · EPSS 3,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • lighttpd Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.4.67-1

    Actualiza a 1.4.67-1

  • lighttpd Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.4.67-1

    Actualiza a 1.4.67-1

  • lighttpd Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.4.67-1

    Actualiza a 1.4.67-1

  • lighttpd Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.4.31-3ubuntu3
    • 1.4.33-1ubuntu1
    • 1.4.33-1+nmu2ubuntu1
    • 1.4.33-1+nmu2ubuntu2
    • 1.4.33-1+nmu2ubuntu2.1
    • 1.4.33-1+nmu2ubuntu2.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • lighttpd Ubuntu:22.04:LTS

    Versiones
    • 1.4.59-1ubuntu2
    • 1.4.59-1ubuntu3
    • 1.4.63-1ubuntu1
    • 1.4.63-1ubuntu2
    • 1.4.63-1ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.4.63-1ubuntu3.1

    Actualiza a 1.4.63-1ubuntu3.1

Fuentes originales

Comprueba tu servidor →