p PatchFirst

CVE-2022-41556

CVE-2022-41556

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

CVSS 7.5 · Élevée · EPSS 3,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • lighttpd Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.4.67-1

    Mettez à jour vers 1.4.67-1

  • lighttpd Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.4.67-1

    Mettez à jour vers 1.4.67-1

  • lighttpd Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.4.67-1

    Mettez à jour vers 1.4.67-1

  • lighttpd Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 1.4.31-3ubuntu3
    • 1.4.33-1ubuntu1
    • 1.4.33-1+nmu2ubuntu1
    • 1.4.33-1+nmu2ubuntu2
    • 1.4.33-1+nmu2ubuntu2.1
    • 1.4.33-1+nmu2ubuntu2.1+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • lighttpd Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.4.59-1ubuntu2
    • 1.4.59-1ubuntu3
    • 1.4.63-1ubuntu1
    • 1.4.63-1ubuntu2
    • 1.4.63-1ubuntu3
    Plages de versions concernées
    • ECOSYSTEM: < 1.4.63-1ubuntu3.1

    Mettez à jour vers 1.4.63-1ubuntu3.1

Sources originales

Vérifiez votre serveur →