p PatchFirst

CVE-2022-41556

CVE-2022-41556

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

CVSS 7.5 · Hoch · EPSS 3,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • lighttpd Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.67-1

    Auf 1.4.67-1 aktualisieren

  • lighttpd Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.67-1

    Auf 1.4.67-1 aktualisieren

  • lighttpd Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.67-1

    Auf 1.4.67-1 aktualisieren

  • lighttpd Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.4.31-3ubuntu3
    • 1.4.33-1ubuntu1
    • 1.4.33-1+nmu2ubuntu1
    • 1.4.33-1+nmu2ubuntu2
    • 1.4.33-1+nmu2ubuntu2.1
    • 1.4.33-1+nmu2ubuntu2.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • lighttpd Ubuntu:22.04:LTS

    Softwareversionen
    • 1.4.59-1ubuntu2
    • 1.4.59-1ubuntu3
    • 1.4.63-1ubuntu1
    • 1.4.63-1ubuntu2
    • 1.4.63-1ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.63-1ubuntu3.1

    Auf 1.4.63-1ubuntu3.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →