p PatchFirst

CVE-2022-41957

CVE-2022-41957 · muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

CVSS 7.5 · Alta · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • muhammarajs

    Versiones
    • < 2.6.2: Afectada
    • >= 3.0.0, < 3.4.0: Afectada

    Sin corrección publicada

  • hummus npm

    Intervalos de versiones afectados
    • SEMVER: (−∞, +∞)

    Sin corrección publicada

  • muhammara npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.4.0

    Actualiza a 3.4.0

  • muhammara npm

    Intervalos de versiones afectados
    • SEMVER: < 2.6.2

    Actualiza a 2.6.2

Fuentes originales

Comprueba tu servidor →