p PatchFirst

CVE-2022-41957

CVE-2022-41957 · muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

CVSS 7.5 · Hoch · EPSS 1,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • muhammarajs

    Softwareversionen
    • < 2.6.2: Betroffen
    • >= 3.0.0, < 3.4.0: Betroffen

    Keine Korrektur veröffentlicht

  • hummus npm

    Betroffene Versionsbereiche
    • SEMVER: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • muhammara npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.4.0

    Auf 3.4.0 aktualisieren

  • muhammara npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.6.2

    Auf 2.6.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →