p PatchFirst

CVE-2022-41957

CVE-2022-41957 · muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

CVSS 7.5 · High · EPSS 1.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • muhammarajs

    Versions
    • < 2.6.2: Affected
    • >= 3.0.0, < 3.4.0: Affected

    No fix published

  • hummus npm

    Affected ranges
    • SEMVER: (−∞, +∞)

    No fix published

  • muhammara npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.4.0

    Update to 3.4.0

  • muhammara npm

    Affected ranges
    • SEMVER: < 2.6.2

    Update to 2.6.2

Original sources

Check your server →