p PatchFirst

CVE-2023-23914

CVE-2023-23914

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality fail when multiple URLs are requested serially. Using its HSTS support, curl can be instructed to use HTTPS instead of usingan insecure clear-text HTTP step even when HTTP is provided in the URL. ThisHSTS mechanism would however surprisingly be ignored by subsequent transferswhen done on the same command line because the state would not be properlycarried on.

CVSS 9.1 · Crítica · EPSS 0,9% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • https://github.com/curl/curl

    Versiones
    • Fixed in 7.88.0: Afectada

    Sin corrección publicada

  • curl Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.88.1-1

    Actualiza a 7.88.1-1

  • curl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.88.1-1

    Actualiza a 7.88.1-1

  • curl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.88.1-1

    Actualiza a 7.88.1-1

  • curl Ubuntu:22.04:LTS

    Versiones
    • 7.74.0-1.3ubuntu2
    • 7.74.0-1.3ubuntu3
    • 7.80.0-3
    • 7.81.0-1
    • 7.81.0-1ubuntu1.1
    • 7.81.0-1ubuntu1.2
    • 7.81.0-1ubuntu1.3
    • 7.81.0-1ubuntu1.4
    • 7.81.0-1ubuntu1.6
    • 7.81.0-1ubuntu1.7
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.81.0-1ubuntu1.8

    Actualiza a 7.81.0-1ubuntu1.8

Fuentes originales

Comprueba tu servidor →