CVE-2023-23914
CVE-2023-23914
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality fail when multiple URLs are requested serially. Using its HSTS support, curl can be instructed to use HTTPS instead of usingan insecure clear-text HTTP step even when HTTP is provided in the URL. ThisHSTS mechanism would however surprisingly be ignored by subsequent transferswhen done on the same command line because the state would not be properlycarried on.
CVSS 9.1 · Critique · EPSS 0,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
https://github.com/curl/curl
- Versions du logiciel
- Fixed in 7.88.0: Concernée
Aucun correctif publié
curl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 7.88.1-1
Mettez à jour vers 7.88.1-1
curl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 7.88.1-1
Mettez à jour vers 7.88.1-1
curl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 7.88.1-1
Mettez à jour vers 7.88.1-1
curl Ubuntu:22.04:LTS
- Versions du logiciel
- 7.74.0-1.3ubuntu2
- 7.74.0-1.3ubuntu3
- 7.80.0-3
- 7.81.0-1
- 7.81.0-1ubuntu1.1
- 7.81.0-1ubuntu1.2
- 7.81.0-1ubuntu1.3
- 7.81.0-1ubuntu1.4
- 7.81.0-1ubuntu1.6
- 7.81.0-1ubuntu1.7
- Plages de versions concernées
- ECOSYSTEM: < 7.81.0-1ubuntu1.8
Mettez à jour vers 7.81.0-1ubuntu1.8