CVE-2023-23914
CVE-2023-23914
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality fail when multiple URLs are requested serially. Using its HSTS support, curl can be instructed to use HTTPS instead of usingan insecure clear-text HTTP step even when HTTP is provided in the URL. ThisHSTS mechanism would however surprisingly be ignored by subsequent transferswhen done on the same command line because the state would not be properlycarried on.
CVSS 9.1 · Kritisch · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
https://github.com/curl/curl
- Softwareversionen
- Fixed in 7.88.0: Betroffen
Keine Korrektur veröffentlicht
curl Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.88.1-1
Auf 7.88.1-1 aktualisieren
curl Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.88.1-1
Auf 7.88.1-1 aktualisieren
curl Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.88.1-1
Auf 7.88.1-1 aktualisieren
curl Ubuntu:22.04:LTS
- Softwareversionen
- 7.74.0-1.3ubuntu2
- 7.74.0-1.3ubuntu3
- 7.80.0-3
- 7.81.0-1
- 7.81.0-1ubuntu1.1
- 7.81.0-1ubuntu1.2
- 7.81.0-1ubuntu1.3
- 7.81.0-1ubuntu1.4
- 7.81.0-1ubuntu1.6
- 7.81.0-1ubuntu1.7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.81.0-1ubuntu1.8
Auf 7.81.0-1ubuntu1.8 aktualisieren