CVE-2023-37478
CVE-2023-37478 · pnpm incorrectly parses tar archives relative to specification
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.
CVSS 7.5 · Alta · EPSS 1,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
pnpm
- Versiones
- < 7.33.4: Afectada
- >= 8.0.0, < 8.6.8: Afectada
Sin corrección publicada
pnpm npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/exe npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/linux-arm64 npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/linux-x64 npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/linuxstatic-arm64 npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/macos-arm64 npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/macos-x64 npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/win-x64 npm
- Intervalos de versiones afectados
- SEMVER: < 7.33.4
Actualiza a 7.33.4
@pnpm/cafs npm
- Intervalos de versiones afectados
- SEMVER: < 7.0.5
Actualiza a 7.0.5
pnpm npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/exe npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/linux-arm64 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/linux-x64 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/linuxstatic-arm64 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/macos-arm64 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/macos-x64 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8
@pnpm/win-x64 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.0.0, < 8.6.8
Actualiza a 8.6.8