CVE-2023-37478
CVE-2023-37478 · pnpm incorrectly parses tar archives relative to specification
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.
CVSS 7.5 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
pnpm
- Versions
- < 7.33.4: Affected
- >= 8.0.0, < 8.6.8: Affected
No fix published
pnpm npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/exe npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/linux-arm64 npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/linux-x64 npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/linuxstatic-arm64 npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/macos-arm64 npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/macos-x64 npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/win-x64 npm
- Affected ranges
- SEMVER: < 7.33.4
Update to 7.33.4
@pnpm/cafs npm
- Affected ranges
- SEMVER: < 7.0.5
Update to 7.0.5
pnpm npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/exe npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/linux-arm64 npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/linux-x64 npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/linuxstatic-arm64 npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/macos-arm64 npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/macos-x64 npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8
@pnpm/win-x64 npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.6.8
Update to 8.6.8