p PatchFirst

CVE-2023-37478

CVE-2023-37478 · pnpm incorrectly parses tar archives relative to specification

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.

CVSS 7.5 · Hoch · EPSS 1,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • pnpm

    Softwareversionen
    • < 7.33.4: Betroffen
    • >= 8.0.0, < 8.6.8: Betroffen

    Keine Korrektur veröffentlicht

  • pnpm npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/exe npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/linux-arm64 npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/linux-x64 npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/linuxstatic-arm64 npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/macos-arm64 npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/macos-x64 npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/win-x64 npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.33.4

    Auf 7.33.4 aktualisieren

  • @pnpm/cafs npm

    Betroffene Versionsbereiche
    • SEMVER: < 7.0.5

    Auf 7.0.5 aktualisieren

  • pnpm npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/exe npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/linux-arm64 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/linux-x64 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/linuxstatic-arm64 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/macos-arm64 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/macos-x64 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

  • @pnpm/win-x64 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Auf 8.6.8 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →