CVE-2023-49582
CVE-2023-49582 · Apache Portable Runtime (APR): Unexpected lax shared memory permissions
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.
CVSS 5.5 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache portable runtime (apr)
- Versiones
- ≥ 0.9.0, ≤ 1.7.4: Afectada (semver)
Sin corrección publicada
apr Debian:12
- Versiones
- 1.7.2-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.2-3+deb12u1
Actualiza a 1.7.2-3+deb12u1
apr Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.5-1
Actualiza a 1.7.5-1
apr Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.5-1
Actualiza a 1.7.5-1
apr Ubuntu:Pro:14.04:LTS
- Versiones
- 1.4.8-1ubuntu1
- 1.4.8-2
- 1.4.8-3
- 1.5.0-1
- 1.5.0-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm2
Actualiza a 1.5.0-1ubuntu0.1~esm2
apr Ubuntu:Pro:16.04:LTS
- Versiones
- 1.5.2-3
- 1.5.2-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm2
Actualiza a 1.5.2-3ubuntu0.1~esm2
apr Ubuntu:Pro:18.04:LTS
- Versiones
- 1.6.2-1
- 1.6.3-1
- 1.6.3-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.3-2ubuntu0.1~esm1
Actualiza a 1.6.3-2ubuntu0.1~esm1
apr Ubuntu:20.04:LTS
- Versiones
- 1.6.5-1
- 1.6.5-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.5-1ubuntu1.1
Actualiza a 1.6.5-1ubuntu1.1
apr Ubuntu:22.04:LTS
- Versiones
- 1.7.0-6ubuntu1
- 1.7.0-8
- 1.7.0-8build1
- 1.7.0-8ubuntu0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.0-8ubuntu0.22.04.2
Actualiza a 1.7.0-8ubuntu0.22.04.2
apr Ubuntu:24.04:LTS
- Versiones
- 1.7.2-3
- 1.7.2-3.1build1
- 1.7.2-3.1build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.2-3.1ubuntu0.1
Actualiza a 1.7.2-3.1ubuntu0.1