p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apr

Vulnerabilidades publicadas para apr en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 8

  1. CVE-2023-49582

    Media · CVSS 5.5EPSS 0,33%Corrección disponible

    Apache Portable Runtime (APR): Unexpected lax shared memory permissions

    Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.

    • Actualiza a 1.7.5-1
    Publicación Actualización
  2. CVE-2022-24963

    Crítica · CVSS 9.8EPSS 1,47%Corrección disponible

    Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions

    Integer Overflow or Wraparound vulnerability in apr_encode functions of Apache Portable Runtime (APR) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime (APR) version 1.7.0.

    • Actualiza a 1.7.2-1
    Publicación Actualización
  3. CVE-2021-35940

    Alta · CVSS 7.1EPSS 1,19%Corrección disponible

    Regression of CVE-2017-12613

    An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

    • Actualiza a 1.7.0-7
    Publicación Actualización
  4. CVE-2017-12613

    Alta · CVSS 7.1EPSS 1,75%Corrección disponible

    CVE-2017-12613

    When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be accessed in converting this value to an apr_time_exp_t value, potentially revealing the contents of a different static heap value or resulting in program termination, and may represent an information disclosure or denial of service vulnerability to applications which call these APR functions with unvalidated external input.

    • Actualiza a 1.6.3-1
    Publicación Actualización
  5. CVE-2012-0840

    Sin evaluarEPSS 42,14%Código de explotación públicoCorrección disponible

    CVE-2012-0840

    tables/apr_hash.c in the Apache Portable Runtime (APR) library through 1.4.5 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.

    • Actualiza a 1.4.6-1
    Publicación Actualización
  6. CVE-2011-1928

    Sin evaluarEPSS 10,32%Corrección disponible

    CVE-2011-1928

    The fnmatch implementation in apr_fnmatch.c in the Apache Portable Runtime (APR) library 1.4.3 and 1.4.4, and the Apache HTTP Server 2.2.18, allows remote attackers to cause a denial of service (infinite loop) via a URI that does not match unspecified types of wildcard patterns, as demonstrated by attacks against mod_autoindex in httpd when a /*/WEB-INF/ configuration pattern is used. NOTE: this issue exists because of an incorrect fix for CVE-2011-0419.

    • Actualiza a 1.4.5-1
    Publicación Actualización
  7. CVE-2011-0419

    Sin evaluarEPSS 30,41%Código de explotación públicoCorrección disponible

    CVE-2011-0419

    Stack consumption vulnerability in the fnmatch implementation in apr_fnmatch.c in the Apache Portable Runtime (APR) library before 1.4.3 and the Apache HTTP Server before 2.2.18, and in fnmatch.c in libc in NetBSD 5.1, OpenBSD 4.8, FreeBSD, Apple Mac OS X 10.6, Oracle Solaris 10, and Android, allows context-dependent attackers to cause a denial of service (CPU and memory consumption) via *? sequences in the first argument, as demonstrated by attacks against mod_autoindex in httpd.

    • Actualiza a 1.4.4-1
    Publicación Actualización
  8. CVE-2009-2412

    Sin evaluarEPSS 13,78%Corrección disponible

    CVE-2009-2412

    Multiple integer overflows in the Apache Portable Runtime (APR) library and the Apache Portable Utility library (aka APR-util) 0.9.x and 1.3.x allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger crafted calls to the (1) allocator_alloc or (2) apr_palloc function in memory/unix/apr_pools.c in APR; or crafted calls to the (3) apr_rmm_malloc, (4) apr_rmm_calloc, or (5) apr_rmm_realloc function in misc/apr_rmm.c in APR-util; leading to buffer overflows. NOTE: some of these details are obtained from third party information.

    • Actualiza a 1.3.8-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →