p PatchFirst

CVE-2023-49582

CVE-2023-49582 · Apache Portable Runtime (APR): Unexpected lax shared memory permissions

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.

CVSS 5.5 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache portable runtime (apr)

    Softwareversionen
    • ≥ 0.9.0, ≤ 1.7.4: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • apr Debian:12

    Softwareversionen
    • 1.7.2-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.2-3+deb12u1

    Auf 1.7.2-3+deb12u1 aktualisieren

  • apr Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.5-1

    Auf 1.7.5-1 aktualisieren

  • apr Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.5-1

    Auf 1.7.5-1 aktualisieren

  • apr Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.4.8-1ubuntu1
    • 1.4.8-2
    • 1.4.8-3
    • 1.5.0-1
    • 1.5.0-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm2

    Auf 1.5.0-1ubuntu0.1~esm2 aktualisieren

  • apr Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.5.2-3
    • 1.5.2-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm2

    Auf 1.5.2-3ubuntu0.1~esm2 aktualisieren

  • apr Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.6.2-1
    • 1.6.3-1
    • 1.6.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.3-2ubuntu0.1~esm1

    Auf 1.6.3-2ubuntu0.1~esm1 aktualisieren

  • apr Ubuntu:20.04:LTS

    Softwareversionen
    • 1.6.5-1
    • 1.6.5-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.5-1ubuntu1.1

    Auf 1.6.5-1ubuntu1.1 aktualisieren

  • apr Ubuntu:22.04:LTS

    Softwareversionen
    • 1.7.0-6ubuntu1
    • 1.7.0-8
    • 1.7.0-8build1
    • 1.7.0-8ubuntu0.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.0-8ubuntu0.22.04.2

    Auf 1.7.0-8ubuntu0.22.04.2 aktualisieren

  • apr Ubuntu:24.04:LTS

    Softwareversionen
    • 1.7.2-3
    • 1.7.2-3.1build1
    • 1.7.2-3.1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.2-3.1ubuntu0.1

    Auf 1.7.2-3.1ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →