CVE-2024-47875
CVE-2024-47875 · DOMPurify nesting-based mXSS
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. This vulnerability is fixed in 2.5.0 and 3.1.3.
CVSS 10.0 · Crítica · EPSS 1,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
dompurify
- Versiones
- < 2.5.0: Afectada
- < 3.1.3: Afectada
Sin corrección publicada
cacti Debian:12
- Versiones
- 1.2.24+ds1-1
- 1.2.24+ds1-1+deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.24+ds1-1+deb12u2
Actualiza a 1.2.24+ds1-1+deb12u2
cacti Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.26+ds1-1
Actualiza a 1.2.26+ds1-1
cacti Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.26+ds1-1
Actualiza a 1.2.26+ds1-1
node-dompurify Debian:12
- Versiones
- 2.4.1+dfsg+~2.4.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.1+dfsg+~2.4.0-2
Actualiza a 2.4.1+dfsg+~2.4.0-2
node-dompurify Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.6+dfsg+~3.0.5-1
Actualiza a 3.1.6+dfsg+~3.0.5-1
node-dompurify Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.6+dfsg+~3.0.5-1
Actualiza a 3.1.6+dfsg+~3.0.5-1
dompurify npm
- Intervalos de versiones afectados
- SEMVER: < 2.5.0
Actualiza a 2.5.0
dompurify npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.0.0, < 3.1.3
Actualiza a 3.1.3
node-dompurify Ubuntu:22.04:LTS
- Versiones
- 2.3.0+dfsg-2
- 2.3.3+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-dompurify Ubuntu:24.04:LTS
- Versiones
- 2.4.1+dfsg+~2.4.0-1
- 3.0.9+dfsg+~3.0.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-dompurify Ubuntu:25.10
- Versiones
- 3.1.7+dfsg+~3.0.5-1
- 3.1.7+dfsg+~3.0.5-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-dompurify Ubuntu:26.10
- Versiones
- 3.3.3+dfsg-1
- 3.4.2+dfsg-1
- 3.4.5+dfsg-1
- 3.4.12+dfsg-1
- 3.4.13+dfsg-1
- 3.4.13+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-dompurify Ubuntu:26.04:LTS
- Versiones
- 3.1.7+dfsg+~3.0.5-2
- 3.3.3+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/cure53/DOMPurify/security/advisories/GHSA-gx9m-whjm-85jf
- https://github.com/cure53/DOMPurify/commit/0ef5e537a514f904b6aa1d7ad9e749e365d7185f
- https://github.com/cure53/DOMPurify/commit/6ea80cd8b47640c20f2f230c7920b1f4ce4fdf7a
- https://github.com/cure53/DOMPurify/blob/0ef5e537a514f904b6aa1d7ad9e749e365d7185f/test/test-suite.js#L2098
- http://seclists.org/fulldisclosure/2025/Apr/14
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47875