CVE-2024-47875
CVE-2024-47875 · DOMPurify nesting-based mXSS
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. This vulnerability is fixed in 2.5.0 and 3.1.3.
CVSS 10.0 · Critique · EPSS 1,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
dompurify
- Versions du logiciel
- < 2.5.0: Concernée
- < 3.1.3: Concernée
Aucun correctif publié
cacti Debian:12
- Versions du logiciel
- 1.2.24+ds1-1
- 1.2.24+ds1-1+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 1.2.24+ds1-1+deb12u2
Mettez à jour vers 1.2.24+ds1-1+deb12u2
cacti Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.2.26+ds1-1
Mettez à jour vers 1.2.26+ds1-1
cacti Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.2.26+ds1-1
Mettez à jour vers 1.2.26+ds1-1
node-dompurify Debian:12
- Versions du logiciel
- 2.4.1+dfsg+~2.4.0-1
- Plages de versions concernées
- ECOSYSTEM: < 2.4.1+dfsg+~2.4.0-2
Mettez à jour vers 2.4.1+dfsg+~2.4.0-2
node-dompurify Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.1.6+dfsg+~3.0.5-1
Mettez à jour vers 3.1.6+dfsg+~3.0.5-1
node-dompurify Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.1.6+dfsg+~3.0.5-1
Mettez à jour vers 3.1.6+dfsg+~3.0.5-1
dompurify npm
- Plages de versions concernées
- SEMVER: < 2.5.0
Mettez à jour vers 2.5.0
dompurify npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.1.3
Mettez à jour vers 3.1.3
node-dompurify Ubuntu:22.04:LTS
- Versions du logiciel
- 2.3.0+dfsg-2
- 2.3.3+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-dompurify Ubuntu:24.04:LTS
- Versions du logiciel
- 2.4.1+dfsg+~2.4.0-1
- 3.0.9+dfsg+~3.0.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-dompurify Ubuntu:25.10
- Versions du logiciel
- 3.1.7+dfsg+~3.0.5-1
- 3.1.7+dfsg+~3.0.5-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-dompurify Ubuntu:26.10
- Versions du logiciel
- 3.3.3+dfsg-1
- 3.4.2+dfsg-1
- 3.4.5+dfsg-1
- 3.4.12+dfsg-1
- 3.4.13+dfsg-1
- 3.4.13+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-dompurify Ubuntu:26.04:LTS
- Versions du logiciel
- 3.1.7+dfsg+~3.0.5-2
- 3.3.3+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/cure53/DOMPurify/security/advisories/GHSA-gx9m-whjm-85jf
- https://github.com/cure53/DOMPurify/commit/0ef5e537a514f904b6aa1d7ad9e749e365d7185f
- https://github.com/cure53/DOMPurify/commit/6ea80cd8b47640c20f2f230c7920b1f4ce4fdf7a
- https://github.com/cure53/DOMPurify/blob/0ef5e537a514f904b6aa1d7ad9e749e365d7185f/test/test-suite.js#L2098
- http://seclists.org/fulldisclosure/2025/Apr/14
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47875