CVE-2024-47875
CVE-2024-47875 · DOMPurify nesting-based mXSS
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. This vulnerability is fixed in 2.5.0 and 3.1.3.
CVSS 10.0 · Kritisch · EPSS 1,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
dompurify
- Softwareversionen
- < 2.5.0: Betroffen
- < 3.1.3: Betroffen
Keine Korrektur veröffentlicht
cacti Debian:12
- Softwareversionen
- 1.2.24+ds1-1
- 1.2.24+ds1-1+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.2.24+ds1-1+deb12u2
Auf 1.2.24+ds1-1+deb12u2 aktualisieren
cacti Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.2.26+ds1-1
Auf 1.2.26+ds1-1 aktualisieren
cacti Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.2.26+ds1-1
Auf 1.2.26+ds1-1 aktualisieren
node-dompurify Debian:12
- Softwareversionen
- 2.4.1+dfsg+~2.4.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.1+dfsg+~2.4.0-2
Auf 2.4.1+dfsg+~2.4.0-2 aktualisieren
node-dompurify Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.6+dfsg+~3.0.5-1
Auf 3.1.6+dfsg+~3.0.5-1 aktualisieren
node-dompurify Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.6+dfsg+~3.0.5-1
Auf 3.1.6+dfsg+~3.0.5-1 aktualisieren
dompurify npm
- Betroffene Versionsbereiche
- SEMVER: < 2.5.0
Auf 2.5.0 aktualisieren
dompurify npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.1.3
Auf 3.1.3 aktualisieren
node-dompurify Ubuntu:22.04:LTS
- Softwareversionen
- 2.3.0+dfsg-2
- 2.3.3+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:24.04:LTS
- Softwareversionen
- 2.4.1+dfsg+~2.4.0-1
- 3.0.9+dfsg+~3.0.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:25.10
- Softwareversionen
- 3.1.7+dfsg+~3.0.5-1
- 3.1.7+dfsg+~3.0.5-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:26.10
- Softwareversionen
- 3.3.3+dfsg-1
- 3.4.2+dfsg-1
- 3.4.5+dfsg-1
- 3.4.12+dfsg-1
- 3.4.13+dfsg-1
- 3.4.13+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:26.04:LTS
- Softwareversionen
- 3.1.7+dfsg+~3.0.5-2
- 3.3.3+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/cure53/DOMPurify/security/advisories/GHSA-gx9m-whjm-85jf
- https://github.com/cure53/DOMPurify/commit/0ef5e537a514f904b6aa1d7ad9e749e365d7185f
- https://github.com/cure53/DOMPurify/commit/6ea80cd8b47640c20f2f230c7920b1f4ce4fdf7a
- https://github.com/cure53/DOMPurify/blob/0ef5e537a514f904b6aa1d7ad9e749e365d7185f/test/test-suite.js#L2098
- http://seclists.org/fulldisclosure/2025/Apr/14
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47875