p PatchFirst

CVE-2025-21617

CVE-2025-21617 · Guzzle OAuth Subscriber has insufficient nonce entropy

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

CVSS 6.3 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • oauth-subscriber

    Versiones
    • < 0.8.1: Afectada

    Sin corrección publicada

  • guzzlehttp/oauth-subscriber Packagist

    Versiones
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    • 0.7.0
    • 0.8.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.8.1

    Actualiza a 0.8.1

Fuentes originales

Comprueba tu servidor →