p PatchFirst

CVE-2025-21617

CVE-2025-21617 · Guzzle OAuth Subscriber has insufficient nonce entropy

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

CVSS 6.3 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • oauth-subscriber

    Softwareversionen
    • < 0.8.1: Betroffen

    Keine Korrektur veröffentlicht

  • guzzlehttp/oauth-subscriber Packagist

    Softwareversionen
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    • 0.7.0
    • 0.8.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.8.1

    Auf 0.8.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →