p PatchFirst

CVE-2025-29927

CVE-2025-29927 · Authorization Bypass in Next.js Middleware

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

CVSS 9.1 · Crítica · EPSS 99,2% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next.js

    Versiones
    • >= 11.1.4, < 12.3.5: Afectada
    • >= 14.0.0, < 14.2.25: Afectada
    • >= 15.0.0, < 15.2.3: Afectada
    • >= 13.0.0, < 13.5.9: Afectada

    Sin corrección publicada

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 13.0.0, < 13.5.9

    Actualiza a 13.5.9

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 14.0.0, < 14.2.25

    Actualiza a 14.2.25

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 15.0.0, < 15.2.3

    Actualiza a 15.2.3

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 12.0.0, < 12.3.5

    Actualiza a 12.3.5

Fuentes originales

Comprueba tu servidor →